mercury

Page d'accueil > Mise en route

Mise en route

Data Management est un pack d’administration d’importation de données pour Microsoft System Center 2012 - Service Manager. Utilisez les assistants fournis pour migrer des données à partir d’autres systèmes ou sources dans Service Manager et contrôler la création des données. Vos données peuvent être converties et importées dans la base de données Configuration Manager (CMDB) en tant qu’objets tels que des éléments de configuration. En fonction de vos critères, le pack d’administration mettra à jour les objets existants avec de nouvelles données, ou créera de nouveaux objets. Si les données source contiennent des relations, celles-ci seront maintenues à l’intérieur des nouveaux objets. Les objets associés peuvent également être créés au cours de l’importation. Par exemple, si vous créez un bien matériel avec une entreprise comme fournisseur le bien matériel sera créé avec une association au fournisseur. Si la source contient assez de données concernant le fournisseur, sa création sera également possible.

Un mappage des données est utilisé pour définir les objets et les propriétés qui sont mis à jour ou créés, ainsi que les relations qu’ils entretiennent avec vos données source. Il peut également être utilisé pour modifier les données au cours de l’importation. Si l’objet dispose d’une propriété de Statut, et que les données source contiennent des valeurs de statut incorrectes ou manquantes, vous pourriez remplacer le statut par une valeur par défaut.

Il est également possible d’exporter des données, puis de les réimporter une fois que vous les avez modifiées. Par exemple, vous pourriez exporter des licences logicielles, y ajouter des informations de mise à niveau, puis les réimporter. Utilisez l’assistant Données d’exportation, fourni avec le IT Asset Management Pack, pour créer un fichier CSV à partir des licences. Ajoutez des informations de mise à niveau au fichier, puis utilisez l’assistant Importation Data Management pour réimporter les licences.

Rubriques

Comprendre la terminologie

Fonctionnement de l’importation des données

Comparaison des fonctionnalités des outils d’importation


Comprendre la terminologie

Les termes suivants sont utilisés dans ce document pour décrire les fonctionnalités de Data Management :

Terme | Description
classe | Un groupe de propriétés associées à un objet de destination. Par exemple, la classe Bien matériel définit les propriétés d’un bien matériel, qui incluent un modèle, un fabricant, un statut de cycle de vie, et un emplacement. Le pack d’administration importe les données dans des classes et leurs propriétés. Un élément de configuration est défini par sa classe.
élément de configuration | Tout objet que vous administrez dans le but de fournir un service. Il est possible d’associer des objets à d’autres objets. Il est également possible de leur attribuer un parent ou des enfants. Parmi les éléments de configuration, on citera par exemple les biens matériels, les utilisateurs, les contrats, et les titres de logiciels.
critères | Les critères sont utilisés durant le mappage des objets pour déterminer si une propriété doit être mise à jour ou créée.
fichier csv | Un fichier contenant des valeurs séparées par des virgules, utilisé pour importer des données dans Service Manager.
en-tête | La première ligne de votre base de données ou fichier source, qui décrit le contenu de chaque colonne pour les lignes restantes.
champ | Une valeur ou une cellule unique du fichier source utilisée pour renseigner une ou plusieurs propriétés.
objet | Les termes « objet » et « élément de configuration » sont des synonymes dans ce document. Voir élément de configuration.
instance d'objet | Une instance réelle d'un objet, tel un ordinateur portable T510 ou l'entreprise nommée Lenovo.
projection | Une projection contient une ou plusieurs classes ainsi que les relations associées.
propriété | Une propriété définit un attribut spécifique d’une classe. Par exemple, les propriétés d’un contrat incluent le statut, l’éditeur, les dates, et le gestionnaire du contrat. Les données sont importées dans les propriétés d’une classe.
requête | Une requête renvoie des lignes ou des enregistrements à partir d'une base de données SQL Server ou LDAP Active Directory.
enregistrement | Un enregistrement est une ligne dans un fichier CSV ou une ligne renvoyée par une requête. Une ligne est composée d’une série de champs correspondant aux propriétés d’un objet. Une valeur unique dans la source est utilisée pour créer ou mettre à jour un objet.


Fonctionnement de l’importation des données

Phase d’importation

Description

1. Déterminez le type d’importation

Avec Data Management, vous disposez de plusieurs options pour importer des données dans Service Manager : à partir d'un fichier CSV, d'une base de données ou d'une source LDAP. Déterminez quelle méthode est la plus appropriée dans votre situation, puis entrez les informations de connexion dans l’assistant.

2. Vérifiez les résultats de validation

Les données source sont vérifiées. Consultez Importation d'un fichier CSV et Importation de données SQL Server pour en savoir plus sur les conditions requises.

3. Mappez vos données

Un mappage de données permet de transformer des données source en objets dans la CMDB ou de mettre à jour des objets existants. Créez un mappage à l’aide de l’assistant d’importation et déterminez :

• l’objet que vous souhaitez créer ou mettre à jour.

• les propriétés à importer et celles qui doivent être ignorées. Par exemple, si aucun contenu n’a été renseigné pour la date de réactualisation, il n’est pas nécessaire d’importer des données dans cette propriété. Que votre contenu renferme certaines ou toutes les propriétés de l’objet, vous devez choisir celles que vous souhaitez importer ou ne pas importer. Les propriétés requises, identifiées à l’aide d’un astérisque rouge, doivent obligatoirement contenir des données. Les propriétés requises ne sont pas essentielles lors de la mise à jour des objets existants.

• les modifications à apporter au contenu pendant l’importation. Par exemple, changez la valeur de Remarques pendant l’importation pour que tous les ordinateurs créés disposent d’une valeur différente de l'opération du contenu source. Diverses méthodes sont à votre disposition pour modifier le contenu au cours d’une importation, par exemple la concaténation ou les sous-chaînes. Pour en savoir plus sur les méthodes de modification, veuillez consulter Types de propriétés et actions disponibles et À propos du mappage de données.

• les relations à créer au cours d’une importation. Il se peut que vos données source contiennent des informations liées à plusieurs objets, ce qui signifie que vous pouvez créer des relations entre eux pendant l’importation. Vous pouvez utiliser des valeurs contenues dans vos données source pour les objets associés, ou entrer de nouvelles valeurs.

4. Vérifiez les résultats d’importation

Les données source sont ajoutées en tant que nouveaux objets à Service Manager ou sous forme de mise à jour des objets existants.

Si des erreurs se produisent au cours de l’importation, elles seront résumées parmi les résultats. Le type de gestion des erreurs que vous avez sélectionné au début du processus détermine comment l’importation se déroulera en cas d’erreur. Pour plus d'informations sur la gestion des erreurs, veuillez consulter Options de gestion des erreurs.


Comparaison des fonctionnalités des outils d’importation

Les fonctionnalités de Data Management, d’importation CSV (fournie par Service Manager) sont identifiées ici afin que vous puissiez choisir l'outil le mieux adapté à vos besoins d'importation.

Fonctionnalité | Importation pour Data Management | Importation CSV
Créer des objets | ü | ü
Mettre à jour les objets existants en fonction de certains critères | ü |
Créer et mettre à jour des relations entre les objets | ü |
Créer un objet et le mettre à jour au cours du même processus | ü | ü†
Créer des objets dupliqués | ü |
Fragmenter un objet en plusieurs objets différents (avec des relations) | ü |
Modifier une propriété pendant son importation | ü |
Créer des objets contenant des valeurs différentes pour une propriété spécifique | ü | ü
Créer des objets contenant la même valeur pour une propriété spécifique | ü |
Créer des modèles pour mapper les données source vers des objets et des propriétés de destination | ü |
Prend en charge plusieurs formats de sources de données | ü |
†Vous devez connaître l’ID unique de chaque objet. |  |


À propos du mappage de données

Lorsque vous mappez des données au cours d’une importation, vous définissez les objets qui sont créés ou mis à jour, le contenu importé, et les modifications apportées aux données source, le cas échéant. Ce « mappage des données » couvre tous les aspects nécessaires, y compris l’objet de destination, ses propriétés, et les actions à effectuer sur les données source pendant leur conversion en propriété. Le mappage complet des données peut être enregistré en tant que modèle XML et partagé entre plusieurs systèmes par l'intermédiaire d'une importation de modèles.

Votre mappage dépend du type de propriété. Par exemple, si la propriété est une liste, elle n’est pas traitée de la même manière qu’un champ de texte.

En résumé, un mappage de données vous permet de :

• copier le contenu de votre base de données ou fichier source tel quel

• substituer une partie du contenu source avec de nouvelles valeurs saisies manuellement

• substituer une partie du contenu source avec des valeurs de listes prédéfinies prises en charge par Service Manager

• choisir d’ignorer une propriété particulière, c’est-à-dire de ne saisir aucune valeur pour celle-ci. Cela est utile si vous effectuez la mise à jour d’un objet et que vous ne modifiez pas toutes ses propriétés.

• manipuler le contenu source pendant l’importation, par exemple en
concaténant plusieurs valeurs ensemble

• créer des objets dupliqués à partir du contenu source

• fragmenter le contenu source, c’est-à-dire de créer différents objets selon les relations existantes dans le contenu

Pour obtenir des renseignements supplémentaires sur ces procédures liées au mappage de données, veuillez consulter Types de propriétés et actions disponibles.


Types de propriétés et actions disponibles

Une fois l’objet de destination choisi, vous devez déterminer les propriétés à renseigner et les actions que vous allez effectuer. La propriété doit-elle être copiée directement à partir de la source ? Doit-elle être ignorée (laissée vide ou sans mise à jour) ? Doit-elle être remplacée par une valeur différente de la source ? Chaque propriété, selon sa nature, permet d’effectuer différentes actions. Tous les types de propriétés sont présentés dans le tableau suivant , avec les actions qu’ils permettent d’effectuer lors du mappage des données source.

REMARQUE :

les types de propriétés et les actions décrits ici sont également applicables lors de la création de relations entre des objets.

Type de propriété | Action | Description
Booléenne | Aucun | Ne pas importer de valeur pour la propriété. Laissez une propriété telle quelle si vous modifiez un objet existant, ou si vous n’avez aucun contenu pour la propriété
 | Valeur | La propriété nécessite une valeur booléenne, qui doit être saisie au format True/False.
Date | Aucun | Consultez la propriété Booléenne pour obtenir une description.
 | Copier | Sélectionnez la colonne à partir de la source contenant la date, puis choisissez le format utilisé dans la source. Les formats personnalisés pris en charge pour la date sont décrits par Microsoft comme des chaînes de format DateHeure personnalisées sous .Net Framework 1.1. Généralement, les spécificateurs de format sont : j pour le jour, M pour le mois, a pour l’année, et m pour les minutes. Par exemple, entrez jj/MM/aa pour une date qui apparaît ainsi dans votre source : 06/03/11. Rendez-vous sur http://msdn.microsoft.com pour obtenir des informations supplémentaires sur ce format.
 | Valeur | Sélectionnez une nouvelle date à l’aide de l’outil de sélection. Cette action ne tient pas compte de vos données source.
Décimal | Aucun | Consultez la propriété Booléenne pour obtenir une description.
 | Copier | Utilisez le contenu de votre base de données ou fichier source pour la propriété. Sélectionnez la colonne à partir de votre source correspondant à la propriété en cours d’importation. Une valeur décimale ne peut comporter que trois chiffres après la virgule. Si plus de deux chiffres sont situés après la virgule, la valeur sera arrondie à deux chiffres après la virgule. N’utilisez votre contenu source que s’il est valide pour la propriété. Si votre contenu n’est pas valide, choisissez Valeur pour saisir une valeur correcte manuellement pour la propriété.
 | Valeur | Entrez une nouvelle valeur pour la propriété. Cette action ne tient pas compte des données source. Une valeur décimale ne comporte généralement que deux chiffres après la virgule. Si plus de deux chiffres sont situés après la virgule, la valeur sera arrondie à deux chiffres après la virgule. Chaque objet créé ou mis à jour contiendra la même valeur pour la propriété. Utilisez Valeur lorsque votre source ne contient aucune valeur pour la propriété, ou lorsque vous ne souhaitez pas utiliser la valeur fournie.
Entier | Aucun | Consultez la propriété Booléenne pour obtenir une description.
 | Copier | Consultez la propriété Décimale pour obtenir une description, mais rappelez-vous qu’un entier ne comporte aucune valeur décimale.
 | Valeur | Consultez la propriété Décimale pour obtenir une description.
Liste | Aucun | Consultez la propriété Booléenne pour obtenir une description.
 | Copier la liste | Copie la valeur telle quelle à partir de votre contenu source. Assurez-vous que les valeurs de la source sont valides pour la liste. Si elles ne sont pas valides, utilisez la fonction Recherche de liste pour mapper les valeurs de votre liste source vers les valeurs de liste prédéfinies correctes.
 | Recherche de liste | Utilisez la fonction Recherche de liste dans les situations suivantes : lorsque le contenu source comporte des valeurs différentes de celles qui sont prédéfinies pour une propriété donnée, ou lorsque vous disposez de plusieurs valeurs à mapper pour une propriété. Dans la première situation, si votre source contient 1 et que vous mappez 1 pour la valeur prédéfinie retirée, tous les objets de destination disposeront d’une propriété retirée lorsque la source contient 1. Dans la seconde situation, votre source pourra contenir les valeurs 1, 2, 3, et 4, qui devront correspondre à un statut de cycle de vie spécifique. Utilisez la fonction Recherche de liste pour faire correspondre 1 à installé, 2 à retiré, 3 à enlevé, et 4 à expédié. Les objets créés contiendront les statuts de cycle de vie correspondant aux mappages que vous aurez définis.
 | Valeur de liste | Ignorez les contenus de la base de données ou du fichier source. À la place, sélectionnez une valeur prédéfinie pour la propriété. Chaque objet créé ou mis à jour contiendra la même valeur pour la propriété. Choisissez Valeur de liste lorsque la source ne contient aucune valeur pour la propriété, ou lorsque vous ne souhaitez pas utiliser la valeur fournie.
Chaîne | Aucun | Consultez la propriété Booléenne pour obtenir une description.
 | Concaténer | Créez une chaîne avec plusieurs valeurs pour former une valeur unique pour la propriété. Sélectionnez une ou plusieurs colonnes à partir de votre source pour utiliser dans la chaîne, et combinez-les avec vos propres valeurs textuelles. Par exemple, la propriété Nom du bien pourrait être formée en concaténant deux colonnes et une chaîne de texte : étiquette de bien + « - » + modèle. Le Nom de bien prendrait alors l’apparence suivante : 10074589 - Lenovo ThinkPad 520.
 | Copier | Consultez la propriété Décimale pour obtenir une description.
 | Fragmenter | Utilisez la fonction de fragmentation pour extraire une chaîne à partir de la source en choisissant un délimiteur et la position d’un segment. Par exemple, si la source contient la valeur sn-xyz-001, vous pouvez extraire un des trois segments à l’aide du délimiteur (trait d’union) pour séparer les segments. Dans ce cas, en saisissant le délimiteur – et la position 3, le résultat serait 001. En saisissant la position 2 à la place, le résultat serait xyz.
 | Sous-chaîne | Utilisez une sous-chaîne pour extraire une chaîne à partir de la source en choisissant une position de départ et de fin pour les caractères. Par exemple, si la source contient la valeur Modèle T450 Lenovo ThinkPad, vous pouvez extraire une portion de ce texte à utiliser en guise de valeur. Si la position de départ est 7 et la position de fin est 26, le résultat sera T450 Lenovo ThinkPad.
 | Valeur | Consultez la propriété Décimale pour obtenir une description.


Si la source est différente de la destination

Puisqu’il est possible de changer les données source au cours de l’importation, initialement il n’est pas nécessaire qu’elles soient valides pour l’objet de destination. Par exemple, lorsque vous importez des données dans une liste, si les valeurs provenant de vos données source sont valides pour cette liste, le mappage des données est simplifié. Toutefois, si les valeurs de vos données sont cohérentes pour une liste, mais qu’elles ne sont pas identiques aux valeurs prédéfinies de cette liste, vous devez transformer les données pendant l’importation. Vous devez associer chaque valeur prédéfinie avec une valeur de la source (voir le schéma). Dans cette situation il est important que l'utilisation des valeurs soit cohérente dans votre source. De cette façon, vous pourrez obtenir des résultats cohérents lorsque vous mappez une source de données aux propriétés d'un objet. Par exemple, si vous importez des données dans la propriété Type d’une organisation, une des valeurs prédéfinies proposées pour Type est « Service ». Si vos données contiennent « Serv. », ou une valeur moins parlante, par exemple « 2 », vous pouvez les transformer en valeur « Service ». Utilisez l'action Recherche de liste pour transformer les valeurs de liste.

REMARQUE : si vos données source dépassent la taille maximale autorisée pour une propriété, elle sont tronquées. Les caractères en trop sont retirés au cours de l’importation. Les données n’apparaissent pas tronquées sur le formulaire, même s’il est enregistré.


Procédure d’importation des données

Procédure d'importation des données

En planifiant vos tâches d’importation, vous pouvez réduire le nombre de tentatives de réimportation nécessaires. Choisissez une méthode pour importer vos données en répondant aux questions suivantes : Les données sont-elles au format CSV ? Les données sont-elles dans une base de données SQL Server ? Les données proviennent-elles d'une source LDAP (Lightweight Directory Access Protocol), comme Active Directory ? Envisagez-vous d’importer des données à des dates régulières ? Les importations planifiées s'exécutent avec l'applet de commande PowerShell.

Familiarisez-vous avec les données importées pour prendre des décisions informées lors du mappage de vos données aux propriétés. Manque-t-il des colonnes qui sont requises ? Les en-têtes sont-ils tous présents ? Vous devrez ajouter des champs manquants ou les ignorer pendant l’importation. Est-il nécessaire de modifier les données pour les rendre valides ? Allez-vous créer de nouveaux enregistrements, mettre à jour les enregistrements existants, ou les deux ?

Une autorisation est requise

Toute importation dans Service Manager doit être réalisée par une personne appartenant au rôle Administrateurs de Service Manager. Assurez-vous que votre compte est doté du rôle Administrateurs avant de réaliser une importation. Autre méthode : si vous n'êtes pas doté de ce rôle et que vous tentez une importation, un compte RunAs (Data Management Administration Account) est automatiquement substitué. Le compte RunAs peut effectuer une importation, sous réserve qu'il soit également configuré avec un utilisateur doté du rôle Administrateur. Consultez le Guide de déploiement pour en savoir plus et pour des instructions sur l'utilisation du compte RunAs.

Rubriques

Importation d'un fichier CSV

Importation de données SQL Server

Importation avec PowerShell

Pour importer des données à partir d'un fichier CSV :

Pour importer des données à partir d'une requête SQL Server :

Création et configuration des objets

Options de gestion des erreurs


Importation d'un fichier CSV

Le pack Data Management permet d’importer des données à partir d’un fichier CSV. Contrairement à l’assistant d’importation CSV de SCCM, il n’est pas nécessaire de fournir un fichier XML pour importer un fichier CSV avec Data Management.


Conditions requises pour importer un fichier CSV

Les conditions suivantes sont requises pour importer des données à partir d’un fichier CSV :

• Fermez le fichier s’il est ouvert dans une autre application.

• Assurez-vous que le fichier utilise une virgule en guise de délimiteur.

• Assurez-vous que le fichier comporte des en-têtes. Les en-têtes sont utilisés lors du mappage d’un contenu source à des propriétés. Les en-têtes sont les titres des colonnes de données ; ils sont utilisés par l’assistant lors de la sélection des données source. Si votre fichier source ne comporte pas d’en-tête, c’est la première ligne du fichier qui sera utilisée, et vous ne pourrez donc pas importer la première ligne. De la même façon, les en-têtes devraient correspondre aux données pour que vous puissiez les reconnaitre lors du mappage. Par exemple, si vous importez un bien matériel, l’un des en-têtes devrait être Statut du cycle de vie. De la même manière, le contenu de cette colonne devrait comporter des statuts appropriés pour le cycle de vie. Il n’est pas nécessaire qu’ils soient identiques aux statuts requis, mais ils doivent correspondre au cycle de vie pour que vous puissiez savoir comment mapper vos données aux statuts prédéfinis du bien matériel lors du mappage.

Un aperçu des cinq premières valeurs du fichier CSV est proposé lors de l'importation pour vous permettre de vérifier qu'elle a été correctement configurée.


Pour importer des données à partir d’un fichier délimité

Page d'accueil > Procédure d'importation des données > Importation d'un fichier CSV > Pour importer des données à partir d'un fichier CSV :

Pour importer des données à partir d'un fichier CSV :

  1. Accédez à la vue dans l’espace de travail Data Management > Importer.

  2. Dans le volet Tâches, cliquez sur Importer un fichier CSV. L'Assistant d'importation s'ouvre.

  3. Choisissez une Définition de modèle. Si vous ne souhaitez pas créer de modèle, vous avez la possibilité de ne pas l’enregistrer à la fin de l’assistant.

  4. Sélectionnez une option de gestion des erreurs pour déterminer si l’assistant doit s’arrêter lorsqu’une erreur se produit. .

  5. Cliquez sur Suivant. La page Sélectionner un fichier s’ouvre.

  6. Cliquez sur le bouton Parcourir pour rechercher le fichier à importer.

  7. Cliquez sur Suivant. La page Aperçu de la source s'ouvre. L'aperçu vous permet de déterminer si le fichier source et sa présentation sont conformes à vos attentes. Cliquez sur Précédent si vous souhaitez sélectionner un autre fichier.

  8. Cliquez sur Suivant pour débuter le mappage des données à un objet et ses propriétés.

  9. Continuez avec Création et configuration des objets.


Importation de données SQL Server

Avec le pack Data Management, il est possible d’importer des données par l’intermédiaire d’une requête sur une base de données Microsoft SQL Server.

Conditions prérequises pour une importation SQL Server

Les conditions suivantes sont requises pour importer des données à partir d’une base de données Microsoft SQL Server :

• Prise en charge de Microsoft SQL Server, 2003 ou ultérieur.

• Connaître le nom de votre base de données SQL Server. Il est possible que la liste des serveurs SQL trouvés par l’assistant sur votre réseau ne contienne pas tous les serveurs.

• Le pack d’administration utilise l’authentification Windows pour se connecter à la base de données. Il n’utilise pas les informations de connexion que vous avez fournies pour vous connecter à la console Service Manager. À la place, il se sert des identifiants que vous avez utilisés pour vous connecter à l’ordinateur (le serveur d’administration ou votre ordinateur local si vous utilisez la console distante). Votre compte Windows doit disposer des droits nécessaires pour exécuter des requêtes sur la base de données.

AVERTISSEMENT :

le type de requête que vous pouvez exécuter sur la base de données n’est pas soumis à des restrictions. Toutes les requêtes sont transmises intactes au serveur, y compris celles qui contiennent des actions de suppression.


Pour importer des données à partir d’une requête SQL Server

Page d'accueil > Procédure d'importation des données > Importation de données SQL Server > Pour importer des données à partir d'une requête SQL Server :

Pour importer des données à partir d'une requête SQL Server :

  1. Accédez à la vue dans l’espace de travail Data Management > Importer.

  2. Dans le Volet des tâches, cliquez sur Importer des données SQL Server. L'Assistant d'importation s'ouvre.

  3. Choisissez une Définition de modèle. Si vous ne souhaitez pas créer de modèle, vous avez la possibilité de ne pas l’enregistrer à la fin de l’assistant.

  4. Sélectionnez une option de gestion des erreurs pour déterminer si l’assistant doit s’arrêter lorsqu’une erreur se produit..

  5. Cliquez sur Suivant. La page Entrer les informations de base de donnée et lancer une requête s'ouvre.

  6. Sélectionnez le Nom du serveur de la base de données à partir de la liste des serveurs de base de données détectés sur le réseau. Si un serveur de base de données a été ajouté récemment, il se peut qu’il n’apparaisse pas dans la liste. Si votre serveur de base de données n’apparaît pas dans la liste, entrez son nom manuellement.

  7. Sélectionnez le nom de la base de données à partir de la liste des bases de données détectées sur le serveur ou entrez son nom manuellement.

  8. Cliquez sur Tester la connexion pour vérifier que le pack d’administration peut se connecter à la base de données.

  9. Entrez la requête SQL Server dans le champ Définition de la requête. La requête SQL est enregistrée avec le modèle si vous choisissez de l'enregistrer.

  10. Cliquez sur Suivant. La page Aperçu de la source s'ouvre. L'aperçu vous permet de déterminer si la requête et les informations de connexion renvoient des résultats conformes à vos attentes. Cliquez sur Précédent si vous souhaitez changer la base de données ou la requête.

  11. Cliquez sur Suivant pour mapper les données récupérées à partir de la base de données à un objet et ses propriétés.

  12. Continuez avec Création et configuration des objets.


Importation avec LDAP

Vous pouvez importer des données à partir d'un domaine Active Directory ou d'une unité organisationnelle. Par exemple, vous pourriez importer des utilisateurs, des imprimantes ou des ordinateurs. Comme avec les autres méthodes d'importation, il est possible de mapper ces données à des objets dans Service Manager.

Pour importer des données à partir d'un domaine Active Directory ou d'une unité organisationnelle :

  1. Accédez à la vue dans l’espace de travail Data Management > Importer.

  2. Dans le Volet des tâches, cliquez sur Importer des données LDAP. L'assistant Importation s'ouvre sur la page Choisir le modèle et la gestion des erreurs.

  3. Choisissez une Définition de modèle. Si vous ne souhaitez pas créer de modèle, vous avez la possibilité de ne pas l’enregistrer à la fin de l’assistant.

  4. Sélectionnez une option de gestion des erreurs pour déterminer si l’assistant doit s’arrêter lorsqu’une erreur se produit.

  5. Cliquez sur Suivant. La page Sélectionner un type d’objet/unité organisationnelle/domaine s'ouvre.

  6. Sélectionnez l’unité organisationnelle ou le domaine vers lequel l'assistant va établir la connexion.

  7. Sélectionnez le type d'objet que vous souhaitez importer.

  8. Sous Informations d'identification, sélectionnez le nom du compte à utiliser pour importer les données LDAP.

  9. Il sera peut-être nécessaire d'entrer les informations d'identification avant de pouvoir importer ces objets. Cliquez sur Détails... ou entrez le nom d'utilisateur et le mot de passe lorsqu'ils vous sont demandés.

  10. Cliquez sur Suivant. La page Aperçu de la source s'ouvre. L'aperçu vous permet de déterminer si les résultats retournés sont conformes à vos attentes. Cliquez sur Précédent si vous souhaitez modifier les informations de connexion ou les données à récupérer.

  11. Cliquez sur Suivant pour mapper les données récupérées à partir du répertoire à un objet et ses propriétés.

  12. Continuez avec Création et configuration des objets.


Importation avec PowerShell

Un applet de commande PowerShell (import – servicemanagerdata) est inclus avec Data Management. L’applet de commande vous permet d’importer des données à partir d’une ligne de commande dans des objets Service Manager. Avec PowerShell 2.0 vous pouvez planifier des importations de données dans Service Manager à partir d’autres systèmes. Vous devez vous être familiarisé avec l’utilisation de PowerShell et disposer d’un modèle d’importation existant stocké dans Data Management pouvant servir à mapper les données d’importation.

Le type d’importation choisi - CSV ou SQL Server - dépend des paramètres inclus dans l’appel de la ligne de commande (jeu de paramètres). Par défaut, le jeu de paramètres est prévu pour une importation CSV. Si aucun jeu de paramètres n’est spécifié, PowerShell récupère les valeurs pour les paramètres d’importation CSV obligatoires.

Pour exécuter l’applet de commande PowerShell :

  1. Sur le serveur d’administration Service Manager où vous avez installé le pack Data Management, cliquez sur le menu Démarrer et recherchez le dossier Provance.

  2. Ouvrez le dossier Provance et cliquez sur Provance Data Management Shell. Un invite de commande s’ouvre avec l’applet de commande chargé.

  3. Entrez la commande import-servicemanagerdata et ses paramètres pour exécuter l’applet de commande. Pour en savoir plus, voir Exemples d’appels de l’applet de commande.

REMARQUE :

si vous souhaitez exécuter l’applet de commande à partir d’un invite de commande sans accéder directement au serveur d’administration, il doit être chargé au préalable, consultez Pour charger l’applet de commande PowerShell :.

Pour charger l’applet de commande PowerShell :

Si vous n’exécutez pas l’applet de commande à partir du menu Démarrer, il sera nécessaire de le charger avant de pouvoir l’utiliser. Lorsqu’il est chargé de cette façon, l’applet de commande ne reste pas ouvert entre les sessions ; il doit être chargé avant chaque utilisation pour une nouvelle session.

• Placez le dossier du module \Program Files\Microsoft System Center\Service Manager 2012\Provance\Provance.ServiceManager.Integration.Cmdlets, dans un chemin d’accès du module PowerShell, puis exécutez Import-Module Provance.ServiceManager.Integration.Cmdlets. La variable d’environnement psmodulepath contient les chemins d’accès pour PowerShell.

OU

• Placez le dossier du module Provance.ServiceManager.Integration.Cmdlets dans l’emplacement souhaité, notez le chemin d’accès à partir du répertoire racine, puis exécutez Import-Module "{votre chemin d’accès}\Provance.ServiceManager.Integration.Cmdlets


Paramètres utilisés par l’applet de commande

Le tableau suivant contient une liste des paramètres utilisés par l’applet de commande. Il inclut les paramètres spécifiques à l’importation des données, ainsi que certains paramètres PowerShell généraux qui ont été implémentés. Il est possible de placer les paramètres dans une source séparée, par exemple dans un fichier CSV, qui peut être acheminée dans l’applet de commande. Vous trouverez quelques exemples de ces paramètres dans Exemples d’appels de l’applet de commande.

Paramètre

Type

Description

Nom

spécifique à l’importation

(obligatoire) Le nom du modèle existant (dans Data Management) à utiliser au cours de l’importation. Paramètre sans nom, position 1.

REMARQUE : il n’est pas possible d’acheminer des valeurs à ce paramètre à partir d’un fichier.

OnErrorAction

spécifique à l’importation

L’action à accomplir lorsqu’une erreur se produit pendant le traitement des données. Les valeurs sont Abandonner et Ignorer.
Si une valeur non valide est utilisée, le script utilise la valeur par défaut Abandonner. (Cela ne remplace pas ou n’est pas lié d’aucune façon au paramètre PowerShell par défaut -ErrorAction). Paramètre sans nom, position 2.

REMARQUE : il n’est pas possible d’acheminer des valeurs à ce paramètre à partir d’un fichier.

LiteralPath

importation CSV

(obligatoire) Le chemin d’accès complet, depuis le répertoire racine jusqu’au fichier CSV source, y compris le nom du fichier.

SqlServer

importation SQL Server

(obligatoire) Le serveur sur lequel la base de données SQL source est installée. Le serveur doit être accessible, avec les informations de connexion de l’utilisateur actuel, à partir de l’ordinateur depuis lequel vous exécutez le script.

SqlDatabase

importation SQL Server

(obligatoire) Le nom de la base de données SQL source. La base de données doit être accessible à partir de l’ordinateur sur lequel vous exécutez le script, avec les informations de connexion de l’utilisateur actuel.

Sqlquery

importation SQL Server

(obligatoire) La requête qui récupère vos données source à partir de la base de données. Si la requête contient des caractères d’échappement, enfermez-les dans des guillemets-apostrophes. Les guillemets-apostrophes indiquent que Windows PowerShell ne devrait pas interpréter les caractères en tant que séquence d’échappement.

Verbose

PowerShell

Active l’affichage des messages WriteVerbose inclus dans l’applet de commande. La progression de l’applet de commande est affichée comme suit : heure de début, heure de fin, enregistrements lus, entités créées, et entités mises à jour.

Debug

PowerShell

Active l’affichage des messages WriteDebug inclus dans l’applet de commande. Il vous fournit davantage d’informations au sujet des valeurs retournées à partir des appels de service.

ErrorAction

PowerShell

Contrôle comment PowerShell gère les messages WriteError à partir de l’applet de commande. Il peut comporter les valeurs suivantes :

Continue - PowerShell vous signale lorsque une erreur se produit et continue l’exécution de l’applet de commande.

Inquire - PowerShell met l’applet d’exécution en pause et vous demande comment procéder.

SilentlyContinue - PowerShell continue l’exécution de l’applet de commande sans vous signaler les erreurs.

Stop - PowerShell traite l’erreur comme une TerminatingError et met fin à l’applet de commande.

REMARQUE : il n’est pas possible d’acheminer des valeurs à ce paramètre à partir d’un fichier.

ErrorVariable

PowerShell

Fournit une variable définie par l’utilisateur à l’intérieur de laquelle seront stockés les messages WriteError à la place de la variable $error par défaut. Si le nom de la variable est précédé du préfixe +, les messages s’accumulent ; dans le cas contraire la variable ne conserve que le message d’erreur le plus récent. La syntaxe est la suivante : -ErrorVariable myErr ou -ErrorVariable +myErr,, où myErr est la variable utilisateur.


Exemples d’appels de l’applet de commande

Dans les exemples suivants, le nom du modèle est ‘psimport’.

• Un appel basique de l’applet de commande, spécifiant explicitement le nom des paramètres :

import-servicemanagerdata -name psimport -literalpath "c:\Users\username\documents\test5.csv"

• Un appel basique de l’applet de commande utilisant un appel positionnel pour le nom du modèle :

import-servicemanagerdata psimport -literalpath "c:\Users\username\documents\test3.csv"

• Un appel de l’applet de commande avec les messages Verbose activés :

import-servicemanagerdata -verbose -name psimport -literalpath "c:\Users\username\documents\test5.csv"

• Un appel de l’applet de commande avec la gestion des erreurs contrôlée par l’utilisateur, où la variable utilisateur est ‘myerr’ :

import-servicemanagerdata -verbose psimport -literalpath "c:\Users\username\documents\test3.csv" -erroraction Inquire -errorvariable +myerr

• Acheminement des paramètres d’un fichier vers l’applet de commande :

Import-csv "C:\SqlQuery.csv" | import-servicemanagerdata -name sqlimport -onerroraction skip


Importation par lintermédiaired'unmodèle'

Page d'accueil > Procédure d'importation des données > Importation par l'intermédiaire d'un modèle

Importation par l'intermédiaire d'un modèle

Un modèle d'importation est créé ou modifié au cours du processus d'importation de données. Un modèle peut être enregistré séparément afin de faciliter les importations répétées, puis utilisé pour exécuter une tâche d'importation. Avant de commencer, assurez-vous que le chemin d'accès aux données source auquel il est fait référence dans le modèle est valide. Pour plus d'informations sur les modèles, voir Utilisation de modèles d'importation.

Pour exécuter une tâche d'importation à partir d’un modèle :

  1. Accédez à l'espace de travail Data Management > vue Tous les modèles d’importation.

  2. Sélectionnez votre modèle dans la liste.

  3. Dans le Volet des tâches, cliquez sur Exécuter une tâche à partir d’un modèle. Un message s'affiche indiquant que l'importation a commencé.

  4. Pour consulter le statut de l'importation, accédez à la vue Toutes les tâches d’importation et recherchez le modèle utilisé pour l'importation.

  5. Pour vérifier qu'il n'y ait aucune erreur associée à la tâche, sélectionnez-la et cliquez sur Afficher les détails. L'onglet Détails du traitement présente un résumé des résultats.


Création et configuration des objets

Chaque objet que vous créez dispose de son propre jeu de propriétés à configurer. Les propriétés déterminent le type, ou la classe, d’objet créé, la façon dont ses propriétés uniques sont mappées à vos données source, et si une nouvelle instance d'objet est créée ou si une instance existante est mise à jour. Pour mettre à jour des objets, vous devez entrer des critères afin de trouver les instances concernées. Une fois que toutes vos classes d'objet sont identifiées dans l'assistant d'importation - sous la forme d'une création, d'une mise à jour ou d'une référence - alors vous pouvez ajouter les relations entre elles.

Pour créer et configurer un objet :

  1. Sur la page Ajouter des objets et des relations, cliquez sur Ajouter un objet. L'assistant Ajouter un objet de destination s'ouvre.

  2. Servez-vous des pages de l'assistant pour configurer l'objet : Propriétés générales, Propriétés de mappage et Critères.


Configuration des propriétés générales

Pour configurer les propriétés sur la page Général de l'assistant Ajouter un objet de destination :

  1. Sélectionnez la Classe de l’objet de destination. Il s’agit de l’objet (classe) qui sera créé dans la CMDB. Choisissez une classe d'objet qui correspond aux données source ; par exemple, si vous importez des données contractuelles pour une licence logicielle dans le IT Asset Management Pack, choisissez l'accord approprié, ici Contrat de licence logicielle.

  2. Entrez le nom de l’objet de destination. Le nom est uniquement destiné à vous aider à identifier les objets au sein de l'assistant. Il n’apparaît pas pour les instances d'objet créées après l’importation.

  3. Sélectionnez une des Options de traitement des objets pour déterminer si vous souhaitez que les objets soient créés, mis à jour, ou les deux, en fonction de certains critères. Les critères doivent être définis sur la page Critères.

    Option

    Mappage

    Critères

    Description

    Créer uniquement

    Obligatoire

    Facultatif

    Crée toutes les instances de l'objet.
    Si vous êtes certain que les instances n'existent pas déjà dans la base de
    données, les critères ne sont pas nécessaires et pourraient ralentir l'importation. S'il est possible que les données source puissent résulter en des instances en double, définissez des critères pour les éliminer.

    Créer ou mettre à jour

    Obligatoire

    Obligatoire

    Met à jour toutes les instances de l'objet qui correspondent aux critères. Crée toutes les instances de l'objet qui ne correspondent pas aux critères. Les critères sont alors utilisés pour filtrer les instances que vous souhaitez mettre à jour.

    Mettre à jour uniquement

    Obligatoire

    Obligatoire

    Met à jour toutes les instances de l'objet qui correspondent aux critères. Ignore toutes les instances de l'objet qui ne correspondent pas aux critères.

    Objet de
    référence

    Aucun

    Aucun

    À utiliser uniquement lors de la suppression d'une relation. Cette option indique que n'importe quel élément peut être supprimé de la relation. Dans une relation « une à une », l'instance de l'objet de référence est supprimée. Dans une relation « une à plusieurs », toutes les instances de l'objet de référence sont supprimées. Le mappage et les critères ne sont pas autorisés avec cette option.

    Instance de référence

    Aucun

    Obligatoire

    À utiliser lors de la création, de la mise à jour ou de la suppression d'une relation. Conçue pour identifier une instance spécifique d'un objet dans une relation. Aucune modification n'est réalisée sur l'instance elle-même ; néanmoins, l'instance doit déjà exister ou être créée au cours de l'importation avant de pouvoir utiliser cette option. Le mappage n'est pas autorisé mais les critères sont requis pour identifier l'instance. Par exemple, si vous souhaitez créer la relation Affecté à sur un bien matériel, vous devez identifier l'utilisateur spécifique sur l'objet. Les critères pour l'instance de référence incluraient Alison Kraus afin de garantir qu'elle devienne Affectée à la relation.

    Supprimer

    Obligatoire

    Supprime toutes les instances de l'objet qui correspondent aux critères. Les instances supprimées en utilisant cette option de traitement sont en fait déplacées vers le dossier Éléments supprimés et doivent être supprimées définitivement depuis ce dossier. Les relations sont également supprimées des instances supprimées. Si vous décidez de restaurer une instance du dossier Éléments supprimés, ses relations sont retournées sans modification aucune.

    4. REMARQUE :

    si vous sélectionnez l’option Mettre à jour ou Créer ou mettre à jour, et que vous ne définissez pas de critère, aucun objet ne sera mis à jour.

  4. (Facultatif) Si vous ne souhaitez pas créer d’instance d'objet, en raison de l’aspect de certaines valeurs dans vos données source, sélectionnez la colonne source qui comporte ces valeurs.

  5. Ajoutez une ou plusieurs valeurs à partir de la colonne source.


Configuration des propriétés de mappage

Il est possible de mapper vos données source à toutes, certaines, ou aucune des propriétés d’un objet de destination. Vous pouvez choisir de ne mapper aucune propriété si, par exemple, vous avez choisi de mettre à jour des objets, ou si vous créez des relations entre les objets.

Pour configurer les propriétés sur la page Mappage :

  1. Accédez à la page Mappage. Toutes les propriétés de la classe choisie sur la page Général sont affichées dans la colonne de Destination.

  2. Pour chaque propriété dans la colonne de destination, choisissez une action (voir la figure). L’action identifie comment sera effectué le
    mappage de la source à la destination. Toutes les actions de mappage sont décrites dans Types de propriétés et actions disponibles.

  3. Dans la colonne source, sélectionnez un élément ou entrez une valeur correspondant à l’Action choisie à l’étape 2.

  4. Si vous effectuez la mise à jour d’enregistrements existants, accédez ensuite à la page Critères, ou cliquez sur OK pour terminer la configuration de l’objet ou de la relation.

REMARQUE :

lors de l’importation de biens matériels, le champ Nom du bien du formulaire du bien est intitulé « Nom complet » sur la page Mappage.


Configuration des critères

Le but de la page Critères est de fournir des critères de recherche au cours d’une importation. Cette page peut également identifier une instance spécifique d'un objet lors du travail avec des relations, par exemple l'ordinateur portable T510 dont le numéro de série est 11178430.

Au cours d'une importation, les instances qui respectent les critères sont mises à jour (lorsque l'option de traitement des objets Mettre à jour uniquement est sélectionnée). Si vous avez choisi l’option de traitement des objets Créer ou mettre à jour sur la page Général, les instances qui ne correspondent pas aux critères sont créées. Dans ce cas, vous pourriez utiliser les critères pour éviter la création d'instances dupliquées.

Dans une relation, une instance d'objet qui respecte les critères est ajoutée à la relation ou supprimée de cette dernière. Aucune modification n'est effectuée sur l'instance elle-même. Si aucune instance ne respecte les critères, alors rien n'est ajouté à la relation ou supprimé de cette dernière.

Pour configurer les options à partir de la page Critères :

  1. Importez les données source comme indiqué dans Pour importer des données à partir d'un fichier CSV : ou Pour importer des données à partir d'une requête SQL Server :.

  2. Mappez les données source aux objets de destination comme indiqué dans Configuration des propriétés de mappage.

  3. Accédez à la page Critères, sélectionnez une propriété, puis cliquez sur Ajouter. La propriété est ajoutée au champ des critères. Sélectionnez autant de propriétés que nécessaire pour réduire l’étendue de la recherche.

  4. À partir du menu déroulant adjacent à chaque propriété, sélectionnez la colonne correspondante dans les données source. Ces propriétés et leurs colonnes correspondantes définissent les instances d'objet qui sont mises à jour ou créées ainsi que les instances qui sont ajoutées à une relation ou supprimées d'une relation, selon les Options de traitement des objets sélectionnées sur la page Général.

  5. Cliquez sur OK. L’objet est maintenant configuré.

L’étape suivante consiste à créer des relations entre vos objets. Voir Création de relations entre les objets. Si vous êtes prêt(e) à créer des objets, voir Étape finale de l’assistant d'importation.


Création de relations entre les objets

Vous pouvez créer des relations entre des objets en cours de création ou de mise à jour depuis votre source. Néanmoins, avant de créer des relations, tous les objets de la relation doivent tout d'abord être définis, voir Création et configuration des objets. Vous pouvez sélectionner les objets de la relation dans n'importe quel ordre ; l'assistant d'importation détermine l'objet qui doit être le parent et celui qui doit être l'enfant.

REMARQUE :

consultez le document Provance Class Definitions afin de comprendre le nombre d'objets possibles dans une relation donnée.

Pour créer une relation entre des objets dans vos données :

>> Sur la page Ajouter des objets et des relations, cliquez sur Ajouter une relation. Le formulaire Ajouter une relation s'ouvre. Configurez la relation comme indiqué dans Configuration des propriétés générales, Configuration des propriétés de mappage et Comment créer une relation.

Configuration des propriétés générales

  1. Sur le formulaire Ajouter une relation, sélectionnez un objet dans la relation.

  2. Sélectionnez un second objet de la relation. Sélectionnez les objets dans n'importe quel ordre.

  3. Sélectionnez le type de relation en choisissant une classe. Les classes disponibles changent en fonction des objets sélectionnés. Donnez priorité aux classes Provance par rapport aux autres classes car elles seront plus susceptibles de représenter une relation précise pour les objets.

  4. Entrez le nom de la relation. Ceci vous aidera à identifier la relation pendant votre travail dans l’assistant, comme dans cet exemple de relation entre un article de catalogue de matériel et son fournisseur :

  5. Sélectionnez une option de traitement des relations afin de déterminer comment traiter la relation :

    Créer uniquement

    Créez une relation entre les deux objets. Les objets doivent exister et être identifiés avec les options de traitement des objets Créer, Mettre à jour ou Instance de référence.

    Dans une relation « une à une », l'option Créer ne fonctionne que lorsqu'aucune relation n'existe déjà. Par exemple, si un bien matériel est déjà doté d'une option Affecté à, aucune relation Affecté à supplémentaire ne serait autorisée car le bien ne peut en comporter qu'une seule.

    Dans une relation « une à plusieurs », toute nouvelle relation est créée mais uniquement si cette relation n'existait pas antérieurement. Par exemple, plusieurs coûts liés pourraient être ajoutés à un bien matériel par l'option Créer uniquement mais si l'un de ces coûts liés existait antérieurement, il ne serait pas à nouveau ajouté au bien.

    Pour en savoir plus, voir Comment créer une relation.

    Créer ou Mettre à jour

    Créez une relation entre les deux objets ou modifiez une relation existante. Les objets doivent exister et être identifiés avec les options de traitement des objets Créer, Mettre à jour ou Instance de référence. Afin d'effectuer une création, omettez les critères. Lors de la création d'une relation « une à une », tout relation existante est remplacée. Dans toutes les autres situations, une nouvelle relation est créée. Par exemple, si un bien matériel comporte déjà une option Affecté à, un utilisateur différent remplacerait l'affectation existante.

    Les mises à jour ne sont effectuées que sur des relations comportant des propriétés. Lorsqu'une relation comporte des propriétés, elles sont visibles sur la page Mappage de l'assistant. Vous devez saisir des critères pour trouver une relation. Si la relation correspond aux critères, ses propriétés sont mises à jour. Si aucune
    correspondance n'est trouvée, la relation elle-même est créée.

    Pour en savoir plus, voir Comment créer une relation.

    Mettre à jour
    uniquement

    L'option Mettre à jour uniquement est utilisée lorsque vous souhaitez modifier les propriétés d'une relation, par exemple, le type de gestionnaire de logiciel sur un titre de logiciel. Les mises à jour ne sont effectuées que lorsque les objets source et cible sont trouvés par l'intermédiaire des critères définis pour ces derniers (assistant Objet de destination). Si les objets source et cible de la relation sont introuvables, rien n'est mis à jour. Une mise à jour peut être effectuée dans une relation « une à une » ou relation « une à plusieurs ». Les propriétés de la relation sont définies sur la page Critères de l'assistant Relation.

    REMARQUE : en l'absence d'une relation existante, aucune mise à jour n'est effectuée car on considère qu'il s'agit d'une opération de création. La relation doit être associée à des propriétés pour que la mise à jour ait lieu. Les objets doivent être définis et identifiés avec les options de traitement des objets Créer, Mettre à jour ou Instance de référence.

    Supprimer

    Supprimez toutes les relations du type choisi lorsqu'utilisé en conjonction avec l'option de traitement des objets : Objet de référence. Ne supprimez que la relation qui correspond aux critères définis avec l'option de traitement des objets : instance de référence. Les objets sont conservés.

    Pour en savoir plus, voir Comment supprimer (effacer) une relation.

Configuration des propriétés de mappage

Parfois, des propriétés sont associées aux relations. Dans ce cas, vous pouvez les mapper aux données de votre fichier source. Lorsque vous utilisez l'option Mettre à jour uniquement comme option de traitement des relations, les propriétés d'une relation sont considérées comme la mise à jour.

REMARQUE :

lorsqu'aucune propriété n'est associée à la relation, la page Mappage ne comporte aucun contenu.

  1. Si des propriétés sont associées à la relation, mappez-les sur vos données. Suivez la procédure de mappage des propriétés d'un objet, décrite dans Configuration des propriétés de mappage.

  2. Si aucune propriété n'est répertoriée, cliquez sur OK pour enregistrer la relation.

  3. Ajoutez des relations supplémentaires si besoin.


Comment créer une relation

Craignez-vous d'écraser une relation existante ?

Dans une relation « une à une », vous ne souhaitez peut-être pas écraser la relation existante. Le meilleur moyen de savoir s'il existe un ou plusieurs objets dans une relation est de tenter d'en ajouter plusieurs par l'intermédiaire du formulaire ; si vous pouvez en ajouter plusieurs, alors il s'agit d'une relation « une à plusieurs ». Si vous ne pouvez pas en ajouter plusieurs, il s'agit d'une relation « une à une ».

Oui, je suis inquiet au sujet de l'écrasement :

Vous pouvez ne pas souhaiter ajouter une relation lorsqu'une relation existe déjà ou lorsqu'une instance d'objet spécifique figure dans la relation, par exemple le fournisseur Adobe ne doit pas être supprimé. Dans les deux cas, utilisez l'option de traitement des objets Instance de référence. L'option Instance de référence vous permet d'ajouter des critères afin de rechercher l'instance d'objet. L'avantage d'utiliser l'option Instance de référence par rapport à l'option Mettre à jour, qui peut également être utilisée, est qu'aucune mise à jour n'est requise pour le second objet - vous les associez, tout simplement. Dans la relation, sélectionnez Créer ou Mettre à jour comme option de traitement des relations.

Exemple :

vous souhaitez affecter Wil Smith comme utilisateur d'un bien matériel mais uniquement si aucune autre personne n'est déjà affectée. Une seule affectation est autorisée pour un bien matériel. Vous ajouterez Wil Smith comme critère Instance de référence pour l'objet utilisateur dans le relation.

Non, je ne suis pas inquiet au sujet de l'écrasement :

Dans une relation « une à plusieurs », cela n'a peut-être aucune importance pour vous si une autre relation est ajoutée. Dans une relation « une à une », cela n'a peut-être également aucune importance pour vous si la relation existante est écrasée. Sélectionnez Instance de référence comme option de traitement des objets et Créer ou Mettre à jour comme option de traitement des relations.


Comment supprimer une relation

Page d'accueil > Procédure d'importation des données > Création de relations entre les objets > Comment supprimer (effacer) une relation

Comment supprimer (effacer) une relation

Craignez-vous de supprimer le mauvais objet de la relation ?

Si vous souhaitez supprimer un élément spécifique d'une relation, vous devez ajouter des critères de recherche d'une instance de l'objet. Si vous ne craignez pas de supprimer des éléments, vous pouvez supprimer tout élément de la relation.

La suppression d'une instance d'un objet (marqué actuellement comme en attente de suppression dans la console) supprime toute relation avec d'autres objets.

Oui, je suis inquiet au sujet de la suppression :

Utilisez l'option de traitement des relations Supprimer et l'option de traitement des objets Instance de référence afin que vous puissiez ajouter des critères de recherche d'une instance spécifique de l'objet. Dans ce cas, la relation peut être de type « une à plusieurs » ou vous pouvez ne souhaiter que supprimer le relation qui correspond à des critères spécifiques.

Exemple :

vous souhaitez ne supprimer que l'affectation d'un bien matériel si l'affectation est destinée à Angelica Hudson. Les critères pour le second objet seraient Angelica Hudson.

Non, je ne suis pas inquiet au sujet de la suppression :

Utilisez l'option de traitement des relations Supprimer et l'option de traitement des objets Objet de référence car il n'est pas nécessaire de sélectionner des critères de recherche. L'option Objet de référence supprime toutes les instances des objets de la relation, même s'il s'agit d'une relation « une à plusieurs ».

Exemples :

vous souhaitez supprimer une affectation d'un bien matériel et son affectation à une personne n'a pas d'importance. Vous souhaitez supprimer tous les coûts liés d'un bien matériel.


Étape finale de l’assistant d'importation

Vous avez créé des objets et les avez mappés à vos données source. Vous avez créé des relations entre les objets. Le moment est venu de compléter l’importation en enregistrant le mappage des données en tant que modèle et en traitant toutes les instructions que vous avez fournies au cours des étapes de configuration.

  1. Une fois que vous avez ajouté tous les objets et toutes les relations, cliquez sur Suivant. La page Résultats de validation et création de modèles s’ouvre. La page comporte les résultats d'une validation effectuée sur votre fichier source. Aucune erreur n'est reportée, donc rien ne s'affiche. Les types d'erreurs qui peuvent être reportés incluent les éléments suivants : colonne ajoutée, supprimée ou renommée ; trop de colonnes ou trop peu de colonnes sur une ligne ; et mappage de problèmes qui requièrent une attention spécifique.

    2. REMARQUES :

    si vous recevez le message d’erreur « Au moins un objet doit contenir un mappage pour pouvoir créer le modèle », la cause la plus probable est que vous n'avez pas mappé toutes les valeurs dans le modèle. Vérifiez le mappage des données de chaque objet pour déterminer quelles valeurs ont été oubliées (généralement signalées par des astérisques). Cela peut se produire si vous avez transféré un modèle entre plusieurs systèmes et une valeur n’existe pas ou les GUID ne sont pas les mêmes sur tous les systèmes.

    Si vous recevez le message d'erreur « Le modèle contient une définition non valide », le fichier source ne correspond pas au modèle choisi. Le problème pourrait être causé par des colonnes manquantes ou renommées. Vérifiez les propriétés de l'objet pour les éléments affichés en rouge qui ne correspondent pas à la définition du modèle.

  2. Pour enregistrer le mappage des données en tant que modèle, cliquez sur Enregistrer le modèle. Seuls les auteurs et les administrateurs Service Manager peuvent enregistrer les modèles. Entrez un nom et une description qui vous aideront à le distinguer des autres modèles de la liste.

  3. Pour passer à l’étape suivante de l'importation, cliquez sur Importation. La page des résultats s'ouvre avec le résumé du processus d'importation. Le champ Enregistrements traités vous indique combien d’enregistrements ont réellement été traités avant les erreurs éventuelles. Il ne précise pas combien d’enregistrements ont été créés. La vue Toutes les tâches d’importation contient une liste des objets créés et des objets mis à jour pour chaque tâche.

  4. Pour annuler l'importation avant qu'elle ne commence, cliquez sur Fermer. Si vous avez sélectionné l'option Enregistrer le modèle et lui avez donné un nom, le modèle est toujours sélectionné.

  5. Pour annuler l'importation alors qu'elle est en cours, cliquez sur Annuler. Pour plus d'informations sur l'annulation d'une opération, voir Annulation d'une importation.

Annulation d'une importation

Lorsque vous cliquez sur Annuler alors que l'importation est en cours, le traitement de l'enregistrement en cours se termine avant que l'importation soit annulée. Les enregistrements importés avant l'annulation sont soumis, c'est-à-dire qu'ils ne sont pas supprimés ou décomptés.


Options de gestion des erreurs

Les options suivantes sont disponibles pour la gestion des erreurs :

Option d’erreur

Description

Importer des enregistrements jusqu’à ce qu’une erreur se produise, puis abandonner

L’importation s’arrête à la première erreur et ne reprend pas. Les enregistrements traités avant que l’erreur ne se soit produite sont importés, tandis que les enregistrements restants ne sont pas importés. Dans certains cas, il est cependant possible qu’aucun enregistrement ne soit importé si le traitement n’était pas terminé lorsque l’erreur est survenue.

Même avec cette option sélectionnée, si une erreur se produit pendant la validation des données, les objets créés à partir de la ligne en cours pourront être enregistrés dans la base de données. Les données restantes du fichier ne seront pas traitées. Dans cette situation, le nombre réel d’objets créés ou mis à jour sera inférieur au nombre indiqué dans la vue Toutes les tâches d’importation.

Ignorer les enregistrements contenant des erreurs et continuer l’importation

Tous les enregistrements sans erreur sont importés ; ceux qui ont rencontré des erreurs sont ignorés.


Utilisation de modèles dimportation'

Page d'accueil > Utilisation de modèles d'importation

Utilisation de modèles d'importation

Le mappage des données décrit comment les colonnes de vos données source sont mappées aux propriétés de l’objet. Il est possible d’enregistrer un mappage des données comme modèle XML pour simplifier les tâches d’importation, par exemple l’importation mensuelle à partir d’un système financier. Un modèle est créé ou modifié au cours du processus d'importation de données. Un modèle créé et enregistré au cours d’une importation CSV peut être réutilisé au cours d’une importation SQL Server et vice versa, à condition que les en-têtes correspondent aux données importées. Un modèle contient également des informations concernant la source, et notamment la connexion SQL Server, la requête SQL entrée, le nom du fichier CSV source et les paramètres LDAP. Le modèle se souviendra de sa dernière connexion SQL Server et des détails de la requête, y compris si vous modifiez un modèle CSV qui a été utilisé pour une importation SQL Server à l'origine. Un modèle contenant toutes les informations requises pour effectuer une importation, vous pouvez exécuter une importation directement depuis n'importe quel modèle (vue Tous les modèles d’importation).

Seuls les individus bénéficiant des droits d’auteur et d’administrateur Service Manager sont autorisés à enregistrer les modèles au cours du processus d’importation.

Les modèles peuvent servir entre autres à créer différents objets à partir des mêmes données. Même si vos données source contiennent des colonnes qui correspondent à plusieurs objets, par exemple un bien matériel, un centre de coûts et un emplacement, vous pouvez utiliser un modèle pour créer un seul type d’objet à partir de ces données. Ainsi, un modèle pourrait servir à créer un objet de centre de coûts à partir de vos données. Un autre modèle pourrait servir à créer un bien matériel. Les deux modèles pourraient donc servir à créer des objets différents à partir des mêmes données source.

REMARQUES :

L’heure indiquée dans le champ Dernière modification de la vue Tous les modèles n’est pas l’heure du serveur. Il s’agit de l’heure locale.

Si vous modifiez un fichier CSV qui vous a servi à créer un modèle, notamment en modifiant un en-tête ou en supprimant une colonne, une erreur sera générée lors de la prochaine importation du fichier CSV. Vous pouvez corriger l'erreur en remappant la propriété affectée de l'objet que vous souhaitez créer. Par exemple, si l'en-tête a été renommé, vous remapperez simplement la propriété avec le nouveau nom de l'en-tête.


Enregistrement des modèles d’importation au format XML

Enregistrez un modèle d'importation au format XML en vue d'une utilisation ultérieure dans une autre console Service Manager.

Pour enregistrer un modèle d’importation à utiliser avec une autre console :

  1. Créez un modèle au cours de l’importation des données (dans le cadre de l’assistant Importation).

  2. Accédez à l'espace de travail Data Management > Importer > Afficher tous les modèles.

  3. Sélectionnez le modèle à enregistrer au format XML.

  4. Cliquez sur Enregistrer le modèle au format XML. Le formulaire Enregistrer le modèle au format XML s’ouvre.

  5. Cliquez sur le bouton Parcourir pour entrer un nom de fichier et un chemin d’accès pour le modèle.

  6. Cliquez sur OK pour enregistrer le modèle. Vous pouvez ensuite utiliser la tâche Charger un modèle d’importation pour charger le modèle dans une autre console.


Chargement des modèles d’importation

Un modèle d'importation, de la version 1.2 ou supérieure, qui est enregistré au format XML peut être chargé dans une autre console Service Manager et utilisé pour importer des données. Vous pouvez importer un modèle unique ou plusieurs modèles soit par la tâche, soit par l'applet de commande PowerShell (Import-ProvanceDMPTemplate). Bien que l'applet de commande soit conçu pour importer un modèle unique, vous pouvez importer un répertoire de fichiers à l'aide de la fonctionnalité de cheminement native de PowerShell (voir Exemple d'appels PowerShell).

Lorsqu'ils ont des noms identiques, un modèle d'importation remplace un modèle existant.

Pour charger des modèles d'importation à l'aide de la tâche :

  1. Accédez à la vue dans l’espace de travail Data Management > Importer.

  2. Dans le Volet des tâches, cliquez sur Charger un modèle d’importation. Le formulaire Charger un modèle d’importation s’ouvre.

  3. Cliquez sur le bouton Ajouter Fichiers pour rechercher et ajouter un ou plusieurs fichiers XML à la liste. Lorsque vous chargez un fichier de modèle ayant le même nom qu'un fichier existant, un avertissement s'affiche. Vous pouvez choisir de continuer l'importation ou de supprimer le fichier en double de la liste.

  4. Entrez un nom complet et une description. Le nom et la description attribués au modèle devraient vous permettre de le distinguer facilement dans une liste.

  5. Cliquez sur OK pour charger le ou les fichiers dans la console. Les modèles chargés se trouvent dans la vue Afficher tous les modèles.

Pour charger un modèle d'importation à l'aide du script PowerShell :

  1. Sur le serveur d’administration Service Manager où vous avez installé le pack Data Management, cliquez sur le menu Démarrer et recherchez le dossier Provance.

  2. Ouvrez le dossier Provance et cliquez sur Provance Data Management Shell. Un invite de commande s’ouvre avec l’applet de commande chargé.

  3. Saisissez la commande d'importation et ses paramètres afin d'exécuter l'applet de commande, par exemple Import-ProvanceDMPTemplate -LiteralPath "c:\mypath\myfolder\MyTemplateDefinition.xml" -Name MyImportedTemplate -OnErrorAction skip. Pour en savoir plus, voir Exemple d'appels PowerShell et Paramètres de modèle d'importation PowerShell.

REMARQUE :

si vous souhaitez exécuter l’applet de commande à partir d’une invite de commande sans accéder directement au serveur d’administration, il doit être chargé au préalable, consultez Pour charger l’applet de commande PowerShell :.


Modification des modèles d’importation

La modification d’un modèle s’effectue au cours du processus d’importation des données source. Lorsque vous modifiez le nom du fichier CSV, la requête et les informations de connexion à la base de données SQL Server, et plus important encore, le mappage des propriétés entre votre source et les objets à créer, le modèle est modifié. L'enregistrement de toutes ces modifications dans le modèle existant le met à jour pour l'importation suivante. Il n'est pas nécessaire d'importer les données afin de créer ou de modifier un modèle par l'intermédiaire d'un assistant d'importation. Lorsque vous atteignez la fin d'un assistant d'importation, sélectionnez simplement Enregistrer le modèle et cliquez sur Fermer.


Paramètres de modèle dimportationPowerShell'

Page d'accueil > Utilisation de modèles d'importation > Paramètres de modèle d'importation PowerShell

Paramètres de modèle d'importation PowerShell

Le tableau suivant contient une liste des paramètres utilisés par l’applet de commande. Il inclut les paramètres spécifiques au chargement des modèles d'importation. Pour une description des paramètres généraux de PowerShell qui ont été implémentés, voir les paramètres de type « PowerShell » dans le tableau de Paramètres utilisés par l’applet de commande. Il est possible de placer les paramètres dans une source séparée, par exemple dans un fichier CSV, qui peut être acheminée dans l’applet de commande. Vous trouverez quelques exemples des paramètres d'importation dans Exemple d'appels PowerShell.

Paramètre | Position | Description
- LiteralPath | 0 | (Obligatoire) Le chemin d’accès complet, depuis le répertoire racine jusqu’au fichier de définition de modèles source, y compris le nom du fichier.
- Nom | 1 | (Facultatif) Le nom à utiliser lors de la création d'un nouveau modèle, ou à rechercher lors de la mise à jour d'un modèle existant. Si le nom n'est pas fourni, le nom du fichier sera utilisé à la place.
- OnErrorAction | 2 | (Facultatif) L'action à effectuer si le processus d'importation rencontre une erreur. Les valeurs qui sont comprises incluent Abandonner et Ignorer. Si une valeur non valide est utilisée, ou si aucune valeur n'est fournie, l'applet de commande utilise la valeur par défaut Abandonner. Remarque : cela ne remplace pas ou n’est pas lié d’aucune façon au paramètre Power- Shell par défaut -ErrorAction.


Exemple dappelsPowerShell'

Page d'accueil > Utilisation de modèles d'importation > Exemple d'appels PowerShell

Exemple d'appels PowerShell

• L'appel de base suivant de l'applet de commande importe un seul fichier de définition de modèles, indiquant explicitement les paramètres facultatifs Nom et OnErrorAction :

Import-ProvanceDMPTemplate -LiteralPath "c:\mypath\myfolder\MyTemplateDefinition.xml" -Name MyImportedTemplate -OnErrorAction skip

• Un jeu de commandes avancé qui tente d'importer tous les fichiers xml dans un chemin d'accès à un dossier spécifique :

Get-ChildItem -Path "C:\Users\myfolder\Documents\Exported Templates\*" -Include *.xml | Select-Object -ExpandProperty FullName | Import-ProvanceDMPTemplate -OnErrorAction skip

• Un jeu de commande avancé qui tente d'importer tous les fichiers xml d'un chemin d'accès à un dossier spécifique et qui définit explicitement le paramètre facultatif Nom sur le nom de fichier. Bien que la conversion nom de fichier en nom soit l'action par défaut de l'applet de commande, ce dernier peut définir des noms explicites :

Get-ChildItem -Path "C:\Users\myfolder\Documents\Exported Templates\*" -Include *.xml | % {Import-ProvanceDMPTemplate -LiteralPath $($_.FullName) -Name $($_.BaseName) -OnErrorAction skip}


Considerations legales

Page d'accueil > Considerations legales

Ce document est fourni uniquement à des fins d'information et Provance n'y donne aucune garantie, qu'elle soit explicite ou implicite. Les informations dans ce document, y compris les références externes, peuvent être modifiées sans préavis. L'utilisateur assume l'ensemble des risques découlant de l'utilisation ou des résultats de l'utilisation de ce document. Il doit en outre se conformer à toutes les lois relatives aux droits d'auteur applicables. Sans limitation des droits d'auteur, aucune partie de ce document ne peut être reproduite, stockée ni introduite dans un système de récupération électronique, ni transmise sous aucune forme et par quelque moyen que ce soit (électronique, mécanique, photocopie, enregistrement ou autre) ou pour quelque raison que ce soit, sans l'autorisation écrite explicite de Provance Technologies, Inc.

Provance Technologies, Inc. peut détenir des brevets, des applications de brevet, des droits d'auteur ou autres droits de propriété intellectuelle couvrant le sujet traité dans ce document. Excepté tel qu'explicitement stipulé dans un accord de licence écrit émis par Provance, la fourniture de ce document ne vous octroie aucun droit sur ces brevets, marques de commerce, droits d'auteur ou autre propriété intellectuelle.

Provance Data Management pour System Center Service Manager 2012 R2

© 2014 Provance Technologies, Inc. Tous droits réservés.

Provance Technologies Inc.

2-490 Saint-Joseph Boulevard

Gatineau, Québec

CANADA

J8Y 3Y7

Provance® et le logo Provance sont des marques commerciales ou déposées de Provance Technologies, Inc.

Microsoft, SQL Server, Windows, Windows Server et Active Directory sont des marques de commerce ou des marques déposées de Microsoft.

Toutes les autres marques de commerce sont détenues par leurs propriétaires respectifs.